易语言字符串Ascii编码查看器源码

易语言字符串Ascii编码查看器源码

窗口组件需要两个编辑框,一个输入字符(串),一个输出Ascii编码。

.版本 2
 
.程序集 窗口程序集1
 
.子程序 _查看编码_被单击
.局部变量 长度1, 整数型
.局部变量 文本, 文本型
.局部变量 长度, 整数型
.局部变量 字符, 文本型
 
编码.内容 = “”
文本 = 源串.内容
长度1 = 取文本长度 (文本)
.计次循环首 (长度1, 长度)
    字符 = 取文本中间 (文本, 长度, 1)
    编码.加入文本 (到文本 (取字节集数据 (到字节集 (字符), #整数型)) + “,)
.计次循环尾 ()

发布日期:

所属分类: 易语言 标签: