511遇见易语言软件本地注册验证-6-使用自定义文件完成使用次数验证解锁


1、客户端需要获取机器码

2、解锁端需要获取机器码

3、二者比较绑定一致

4、解锁文件解锁成功后,必须删除,销毁

5、今天自定义扩展名

6、里面的次数需要加密

保护措施

1、改文件属性

2、隐藏

3、系统

4、放到windows目录下

5、对机器码,使用次数,允许运行的次数 加密

软件源码:

.版本 2
.支持库 dp1
 
.程序集 窗口程序集_启动窗口, , , 软件
 
.子程序 __启动窗口_创建完毕, , , 软件
.局部变量 a, 文本型
.局部变量 临时文本, 文本型
.局部变量 分割, 文本型, , "0"
.局部变量 t
.局部变量 n
 
a = 到文本 (系统_取特征码综合 ())
' 写配置项 (取运行目录 () + “\config.poyjl”, “系统”, “机器码”, 到文本 (加密数据 (到字节集 (到文本 (a)), “qqwert”, #RC4算法)))
' 置文件属性 (取运行目录 () + “\config.poyjl”, 24)
.判断开始 (文件是否存在 (取运行目录 () + “\xt-1.dat”) = 假)
    写到文件 (取运行目录 () + “\xt-1.dat”, 加密数据 (到字节集 (a), “qqwert”, #RC4算法))
    置文件属性 (取运行目录 () + “\xt-1.dat”, 24)
    信息框 (“请先运行一下解锁软件”, 0, , )
    结束 ()
.判断 (文件是否存在 (取运行目录 () + “\xt-2.dat”))
    临时文本 = 到文本 (解密数据 (读入文件 (取运行目录 () + “\xt-2.dat”), “asdf”, #RC4算法))
    分割 = 分割文本 (临时文本,||, )
    t = 到整数 (分割 [1])
    n = 到整数 (分割 [2])
    标题 = “软件运行剩余次数:  ” + 到文本 (t - n)
    .如果 (n > t)
        信息框 (“软件已经达到运行次数上限,试用结束!”, 0, , )
        删除文件 (取运行目录 () + “\xt-2.dat”)
        结束 ()
    .否则
        n = n + 1
        写到文件 (取运行目录 () + “\xt-2.dat”, 加密数据 (到字节集 (3” + “||” + 到文本 (n)), “asdf”, #RC4算法))
    .如果结束
.默认
    信息框 (“请联系作者解锁”, 0, , )
    结束 ()
.判断结束
.子程序 _按钮1_被单击, , , 软件
' 标题 = 到文本 (解密数据 (到字节集 (读配置项 (取运行目录 () + “\config.poyjl”, “系统”, “机器码”, )), “qqwert”, #RC4算法))


发布日期:

所属分类: 易语言 标签: