易语言调用变形DLL无参自定义数据类型

视频教程截图

511遇见

DLL源码:

.版本 2
.支持库 spec
 
.子程序 mytest, , 公开
.参数 参数地址, 整数型
.局部变量 类型, 传递参数, 静态, , 必须选中静态
 
类型.A = 511
类型.B = 2019
类型.C = 1234567898765
类型.D = 真
类型.E = “我是DLL里的文本,属于自定义数据类型,将要传递到程序里。”
写到内存 (指针到字节集 (取变量地址 (类型), 4), 参数地址, 4)

自定义数据类型

.版本 2
.支持库 spec
 
.子程序 mytest, , 公开
.参数 参数地址, 整数型
.局部变量 类型, 传递参数, 静态, , 必须选中静态
 
类型.A = 511
类型.B = 2019
类型.C = 1234567898765
类型.D = 真
类型.E = “我是DLL里的文本,属于自定义数据类型,将要传递到程序里。”
写到内存 (指针到字节集 (取变量地址 (类型), 4), 参数地址, 4)

调用变形DLL无参自定义数据类型源码:

.版本 2
.支持库 spec
 
.局部变量 接受, 接受参数
 
置DLL装载目录 ()
DLL命令调用转向 (取运行目录 () + “\mydll.dll”, “mytest”)
mytest (取变量地址 (接受))
编辑框1.加入文本 (到文本 (接受.A) + #换行符)
编辑框1.加入文本 (到文本 (接受.B) + #换行符)
编辑框1.加入文本 (到文本 (接受.C) + #换行符)
编辑框1.加入文本 (到文本 (接受.D) + #换行符)
编辑框1.加入文本 (接受.E)
DLL命令调用转向 (, )

教程下载:


发布日期:

所属分类: 易语言 标签: