易语言汇编主程序和DLL交换数据字节集型

DLL源码:

.版本 2
 
.子程序 dll, , 公开, 1
.参数 保存地址, 整数型
.局部变量 A, 字节集
 
A = 到字节集 (“我是DLL里的字节集型数据。”)
交换变量数据_地址交地址ASM (取变量地址_ASM (A), 保存地址)

动态调用DLL源码:

.版本 2
.支持库 spec
 
dll路径 = 取运行目录 () + “\dll.dll”
 
.子程序 _按钮1_被单击
.局部变量 A, 字节集
.局部变量 地址, 整数型
.局部变量 命令地址, 整数型
.局部变量 参数数据地址, 整数型, , "1"
 
' 1-获取变量地址
地址 = 取变量地址_ASM (A)
' 2-获取函数命令地址
命令地址 = 取DLL命令地址_ASM (dll路径, “dll”)
' 调用这个函数方法,第二个参数 参数数据地址 是数组,必须转换一下
参数数据地址 [1] = 地址
' 4-调用这个命令方法
调用命令_ASM (命令地址, 参数数据地址, )
' 5-输出得到DLL里的字节集资源
调试输出 (到文本 (A))
信息框 (到文本 (A), 0, , )

汇编调用DLL源码:

.版本 2
.支持库 spec
 
.局部变量 地址, 整数型
.局部变量 A, 字节集
 
地址 = 取变量地址_ASM (A)
dll (地址)
调试输出 (到文本 (A))
信息框 (到文本 (A), 0, , )

教程下载:


发布日期:

所属分类: 易语言 标签: