易语言教程-数据库-读取相关数据

本课用的命令
读()
取记录号 ()
取记录数()
到首记录 ()
到尾记录 ()
打开()
关闭()
跳过()
跳到()

511遇见

本课实现功能
读,上一条,下一条,读首记录,读尾记录,读所有记录

教程源码:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

.如果 (打开 (取运行目录 () + “\test.edb”, , , , , , ) = 真)
调试输出 (“打开数据库成功”)
.否则
信息框 (“打开数据库失败!”, 0, , )
.如果结束
到首记录 ()
读数据 ()

.子程序 __启动窗口_将被销毁

关闭 ()

.子程序 _按钮1_被单击, , , 读

读数据 ()
跳过 ()

.子程序 读数据

编辑框1.内容 = 读 (“账号”)
编辑框2.内容 = 读 (“密码”)
标签3.标题 = “[” + 到文本 (取记录数 ()) + “/” + 到文本 (取记录号 ()) + “]”

.子程序 _按钮2_被单击, , , 到首记录

到首记录 ()
读数据 ()

.子程序 _按钮3_被单击, , , 到尾记录

到尾记录 ()
读数据 ()

.子程序 _按钮4_被单击, , , 上一条

跳到 (取记录号 () - 1)
读数据 ()

.子程序 _按钮5_被单击, , , 下一条
.局部变量 取记录号, 整数型

跳到 (取记录号 () + 1)
读数据 ()

.子程序 _按钮6_被单击, , , 读取所有数据
.局部变量 n, 整数型

到首记录 ()
.计次循环首 (取记录数 (), n)
列表框1.加入项目 (到文本 (n) + “、 账号:” + 读 (1) + “ 密码:” + 读 (2), )
跳过 ()
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: