易语言大漠单线程模块制作后台设置绑定窗口句柄

视频教程模块源码

.版本 2

.子程序 ForceUnBindWindow, 整数型, 公开, 强制解除绑定窗口,并释放系统资源.ForceUnBindWindow(返回值:0失败,1成功)
.参数 hwnd, 整数型, , 窗口句柄

返回 (obj.数值方法 (“ForceUnBindWindow”, hwnd))

.子程序 GetBindWindow, 整数型, 公开, 获取当前对象已经绑定的窗口句柄. 无绑定返回0GetBindWindow(返回值窗口句柄)

返回 (obj.数值方法 (“GetBindWindow”, ))

.子程序 IsBind, 整数型, 公开, 判定指定窗口是否已经被后台绑定. (前台无法判定)IsBind(返回值:0没绑定,或者窗口不存在,1已经绑定)
.参数 hwnd, 整数型, , 窗口句柄

返回 (obj.数值方法 (“IsBind”, hwnd))

.子程序 LockDisplay, 整数型, , 锁定指定窗口的图色数据(不刷新).LockDisplay(返回值:0失败,1成功)
.参数 lock, 整数型, , 0关闭锁定,1 开启锁定

返回 (obj.数值方法 (“LockDisplay”, lock))

.子程序 LockInput, 整数型, 公开, 禁止外部输入到指定窗口LockInput(返回值:0失败,1成功)
.参数 lock, 整数型, , 0关闭锁定,1 开启锁定(键盘鼠标都锁定),2 只锁定鼠标,3 只锁定键盘,4 同1,5同3,详见接口说明

返回 (obj.数值方法 (“LockInput”, lock))

.子程序 LockMouseRect, 整数型, 公开, 设置前台鼠标在屏幕上的活动范围.LockMouseRect(返回值:0失败,1成功)
.参数 X1, 整数型, , 区域的左上X坐标. 屏幕坐标.
.参数 Y1, 整数型, , 区域的左上Y坐标. 屏幕坐标.
.参数 X2, 整数型, , 区域的右下X坐标. 屏幕坐标.
.参数 Y2, 整数型, , 区域的右下Y坐标. 屏幕坐标.

返回 (obj.数值方法 (“LockInput”, X1, Y1, X2, Y2))

.子程序 SetAero, 整数型, 公开, 设置开启或者关闭系统的Aero效果. (仅对WIN7及以上系统有效)SetAero(返回值:0失败,1成功)
.参数 enable, 整数型, , 0关闭,1开启

返回 (obj.数值方法 (“SetAero”, enable))

.子程序 SetDisplayDelay, 整数型, 公开, 设置dx截图最长等待时间。内部默认是3000毫秒. 一般用不到调整这个.SetDisplayDelay(返回值:0失败,1成功)
.参数 time, 整数型, , 等待时间,单位是毫秒。 注意这里不能设置的过小,否则可能会导致截图失败,从而导致图色函数和文字识别失败.

返回 (obj.数值方法 (“SetDisplayDelay”, time))

.子程序 SwitchBindWindow, 整数型, 公开, 在不解绑的情况下,切换绑定窗口.(必须是同进程窗口)SwitchBindWindow(返回值:0失败,1成功)
.参数 hwnd, 整数型, , 需要切换过去的窗口句柄

返回 (obj.数值方法 (“SwitchBindWindow”, hwnd))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: