易语言多线程foobar输出辅助信息保存到文本文件

foobar组件的创建

注意:这里创建后返回的句柄是一个数组foobar_hwnd [m] ,因为我们要在多线程里每个窗口都显示

.版本 2
 
.子程序 foobar
.参数 m
.局部变量 foobar
 
foobar_hwnd [m] = dm [m].CreateFoobarRect (gamethwnd [m], 0, 319, 302, 158)
foobar = foobar_hwnd [m]
 
dm [m].FoobarLock (foobar)
' 设置字体
' 设置行距
dm [m].FoobarFillRect (foobar, 0, 0, 302, 158, “0000FF”)
dm [m].FoobarUpdate (foobar)

把多个窗口的信息写入本地txt文件

txt文件命名是采用启动事件。

.版本 2
 
.子程序 foobarsave
.参数 m
.局部变量 foobar, 整数型, , , 句柄
.局部变量 path, 文本型, , , 保存路径
 
path = 取运行目录 () + “\log\” + 到文本 (取现行时间 ()) + “.txt”
 
foobar = foobar_hwnd [m]
dm [m].FoobarSetSave (foobar, path, 1,[%L04d%] (%hh%-%mm%))

发布日期:

所属分类: 易语言 标签: