易语言内存汇编方式调用DLL里的图片资源

DLL图片资源

.版本 2
 
.程序集 程序集1, , , DLL
.程序集变量 图片数组, 字节集, , "0"
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
加入成员 (图片数组, #logo)
加入成员 (图片数组, #ico)
 
.版本 2
 
.图片 logo
.图片 ico

DLL源码:

.版本 2
.支持库 spec
 
.子程序 图片地址, 整数型, 公开
.参数 数组地址, 整数型
 
返回 (取变量数据地址 (图片数组 [数组地址]))
 
.子程序 图片长度, 整数型, 公开
.参数 数组长度, 整数型
 
返回 (取字节集长度 (图片数组 [数组长度]))

易语言调用DLL源码:

.版本 2
 
.DLL命令 图片地址, 整数型, "dll.dll", "图片地址"
    .参数 数组地址, 整数型
 
.DLL命令 图片长度, 整数型, "dll.dll", "图片长度"
    .参数 数组长度, 整数型

易语言调用源码:

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
 
 
.子程序 _按钮1_被单击
.局部变量 pic, 字节集
 
图片框1.图片 = 指针到字节集 (图片地址 (1), 图片长度 (1))
图标 = 指针到字节集 (图片地址 (2), 图片长度 (2))

教程下载:


发布日期:

所属分类: 易语言 标签: