易语言教程删除数组中重复成员方法3

视频教程源码

.版本 2
.支持库 spec

.子程序 _按钮3_被单击, , , 删除数组重复成员-3
.局部变量 成员, 整数型
.局部变量 a, 整数型, , "0"
.局部变量 m, 整数型
.局部变量 i, 整数型
.局部变量 n, 整数型
.局部变量 文本, 文本型

置随机数种子 ()
编辑框2.内容 = “”
.计次循环首 (10, m)
成员 = 多项选择 (取随机数 (1, 10), 1, 2, 3, 4, 5, 6, 7, 8, 9, 10)
加入成员 (a, 成员)
编辑框2.内容 = 编辑框2.内容 + 到文本 (a [m]) + #换行符
.计次循环尾 ()
调试输出 (a)
子_删除数组重复成员3 (a)
调试输出 (a)

.子程序 子_删除数组重复成员3
.参数 a, 整数型, 数组
.局部变量 m, 整数型
.局部变量 n, 整数型
.局部变量 文本, 文本型

编辑框1.内容 = “”
.计次循环首 (取数组成员数 (a), m)
.如果真 (m > 取数组成员数 (a))
跳出循环 ()

.如果真结束
.计次循环首 (取数组成员数 (a) - m, )
n = n + 1
.如果真 (a [m] = a [m + n])
删除成员 (a, m + n, )
n = n - 1
.如果真结束
.如果真 (m + n = 取数组成员数 (a))
n = 0
跳出循环 ()

.如果真结束

.计次循环尾 ()
文本 = 文本 + 到文本 (a [m]) + #换行符
.计次循环尾 ()
编辑框1.内容 = 文本


发布日期:

所属分类: 易语言 标签: