易语言教程执行命令及源码

511遇见

视频教程源码

.版本 2
.支持库 shell
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
.局部变量 文本, 文本型
 
.判断开始 (单选框1.选中)
    通用对话框1.过滤器 = “文档文件(*.doc)|*.doc”
    .如果真 (通用对话框1.打开 () = 真)
        文本 = 通用对话框1.文件名
        编辑框1.内容 = 文本
        执行 (#编辑文档, 文本, , , )
    .如果真结束
 
.判断 (单选框2.选中)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#浏览文件夹, 文本, , , )
    .如果真结束
 
.判断 (单选框3.选中)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#寻找文件, 文本, , , )
    .如果真结束
 
.判断 (单选框4.选中)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#打开文件, 文本, , , )
    .如果真结束
 
.默认
 
.判断结束
 
 
.子程序 __启动窗口_创建完毕
 
组合框1.加入项目 (“编辑文档(*.doc等文件)”, )
组合框1.加入项目 (“浏览文件夹(打开指定的文件夹)”, )
组合框1.加入项目 (“寻找文件(打开指定的文件夹进行文件的寻找)”, )
组合框1.加入项目 (“打开文件(该文件可以是执行文件(EXE)、文档文件或文件夹)”, )
组合框1.现行选中项 = 0
 
.子程序 _按钮2_被单击
.局部变量 文本, 文本型
 
.判断开始 (组合框1.现行选中项 = 0)
    通用对话框1.过滤器 = “文档文件(*.doc)|*.doc”
    .如果真 (通用对话框1.打开 () = 真)
        文本 = 通用对话框1.文件名
        编辑框1.内容 = 文本
        执行 (#编辑文档, 文本, , , )
    .如果真结束
 
.判断 (组合框1.现行选中项 = 1)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#浏览文件夹, 文本, , , )
    .如果真结束
 
.判断 (组合框1.现行选中项 = 2)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#寻找文件, 文本, , , )
    .如果真结束
 
.判断 (组合框1.现行选中项 = 3)
    文本 = 浏览文件夹 (“选择浏览的文件夹”,)
    .如果真 (文本 ≠ “”)
        编辑框1.内容 = 文本
        执行 (#打开文件, 文本, , , )
    .如果真结束
 
.默认
 
.判断结束

运行()和执行()的区别联系

1、如果是对文件操作的话就用执行。如果是对系统方面的话就用运行,运行更多的是exe
2、执行可以执行很多文件,比如打开txt、exe、ppt等,运行是运行一些命令行,win+R
3、运行跟系统的运行命令相似!执行和鼠标双击的打开方式相似!


发布日期:

所属分类: 易语言 标签: