易语言教程执行命令及源码

视频教程源码

  1. .版本 2
  2. .支持库 shell
  3.  
  4. .程序集 窗口程序集_启动窗口
  5.  
  6. .子程序 _按钮1_被单击
  7. .局部变量 文本, 文本型
  8.  
  9. .判断开始 (单选框1.选中)
  10.     通用对话框1.过滤器 = “文档文件(*.doc)|*.doc”
  11.     .如果真 (通用对话框1.打开 () = 真)
  12.         文本 = 通用对话框1.文件名
  13.         编辑框1.内容 = 文本
  14.         执行 (#编辑文档, 文本, , , )
  15.     .如果真结束
  16.  
  17. .判断 (单选框2.选中)
  18.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  19.     .如果真 (文本 ≠ “”)
  20.         编辑框1.内容 = 文本
  21.         执行 (#浏览文件夹, 文本, , , )
  22.     .如果真结束
  23.  
  24. .判断 (单选框3.选中)
  25.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  26.     .如果真 (文本 ≠ “”)
  27.         编辑框1.内容 = 文本
  28.         执行 (#寻找文件, 文本, , , )
  29.     .如果真结束
  30.  
  31. .判断 (单选框4.选中)
  32.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  33.     .如果真 (文本 ≠ “”)
  34.         编辑框1.内容 = 文本
  35.         执行 (#打开文件, 文本, , , )
  36.     .如果真结束
  37.  
  38. .默认
  39.  
  40. .判断结束
  41.  
  42.  
  43. .子程序 __启动窗口_创建完毕
  44.  
  45. 组合框1.加入项目 (“编辑文档(*.doc等文件)”, )
  46. 组合框1.加入项目 (“浏览文件夹(打开指定的文件夹)”, )
  47. 组合框1.加入项目 (“寻找文件(打开指定的文件夹进行文件的寻找)”, )
  48. 组合框1.加入项目 (“打开文件(该文件可以是执行文件(EXE)、文档文件或文件夹)”, )
  49. 组合框1.现行选中项 = 0
  50.  
  51. .子程序 _按钮2_被单击
  52. .局部变量 文本, 文本型
  53.  
  54. .判断开始 (组合框1.现行选中项 = 0)
  55.     通用对话框1.过滤器 = “文档文件(*.doc)|*.doc”
  56.     .如果真 (通用对话框1.打开 () = 真)
  57.         文本 = 通用对话框1.文件名
  58.         编辑框1.内容 = 文本
  59.         执行 (#编辑文档, 文本, , , )
  60.     .如果真结束
  61.  
  62. .判断 (组合框1.现行选中项 = 1)
  63.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  64.     .如果真 (文本 ≠ “”)
  65.         编辑框1.内容 = 文本
  66.         执行 (#浏览文件夹, 文本, , , )
  67.     .如果真结束
  68.  
  69. .判断 (组合框1.现行选中项 = 2)
  70.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  71.     .如果真 (文本 ≠ “”)
  72.         编辑框1.内容 = 文本
  73.         执行 (#寻找文件, 文本, , , )
  74.     .如果真结束
  75.  
  76. .判断 (组合框1.现行选中项 = 3)
  77.     文本 = 浏览文件夹 (“选择浏览的文件夹”,)
  78.     .如果真 (文本 ≠ “”)
  79.         编辑框1.内容 = 文本
  80.         执行 (#打开文件, 文本, , , )
  81.     .如果真结束
  82.  
  83. .默认
  84.  
  85. .判断结束

运行()和执行()的区别联系

1、如果是对文件操作的话就用执行。如果是对系统方面的话就用运行,运行更多的是exe
2、执行可以执行很多文件,比如打开txt、exe、ppt等,运行是运行一些命令行,win+R
3、运行跟系统的运行命令相似!执行和鼠标双击的打开方式相似!


发布日期:

所属分类: 易语言 标签: