易语言教程计次循环首(九九乘法表)

方法一
.版本 2

.子程序 九九乘法表1
.局部变量 乘数a, 整数型
.局部变量 乘数b, 整数型

编辑框1.内容 = “”
.计次循环首 (9, 乘数a)
.计次循环首 (乘数a, 乘数b)
编辑框1.加入文本 (到文本 (乘数b) + “×” + 到文本 (乘数a) + “=” + 到文本 (乘数b × 乘数a) + 字符 (#Tab键))
.计次循环尾 ()
' 延时 (1000)
编辑框1.加入文本 (#换行符)
编辑框1.加入文本 (#换行符)
.计次循环尾 ()
方法二
.版本 2

.子程序 九九乘法表2
.局部变量 乘数a, 整数型
.局部变量 乘数b, 整数型

编辑框1.内容 = “”
.计次循环首 (9, 乘数a)
.计次循环首 (9, 乘数b)
.如果真 (乘数b ≤ 乘数a)
编辑框1.加入文本 (到文本 (乘数b) + “×” + 到文本 (乘数a) + “=” + 到文本 (乘数b × 乘数a) + 字符 (#Tab键))
.如果真结束

.计次循环尾 ()
编辑框1.加入文本 (#换行符)
编辑框1.加入文本 (#换行符)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: