易语言教程循环控制(到循环尾和跳出循环)

一、官方源码

到循环尾
调用格式: 〈无返回值〉 到循环尾 () - 系统核心支持库->流程控制
英文名称:continue
本命令转移当前程序执行位置到当前所处循环体的循环尾语句处。本命令为初级命令。

操作系统需求: Windows、Linux、Unix
跳出循环
调用格式: 〈无返回值〉 跳出循环 () - 系统核心支持库->流程控制
英文名称:break
本命令转移当前程序执行位置到当前所处循环体循环尾语句的下一条语句处。本命令为初级命令。

操作系统需求: Windows、Linux、Unix

二、 教程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 到循环尾
.局部变量 m, 整数型

.判断循环首 (m < 10)
m = m + 1
.如果真 (m = 5)
到循环尾 ()
.如果真结束
画板1.滚动写行 (m)
.判断循环尾 ()

.子程序 _按钮2_被单击, , , 跳出循环
.局部变量 m, 整数型

.判断循环首 (m < 10)
m = m + 1
.如果真 (m = 8)
跳出循环 ()

.如果真结束

画板1.滚动写行 (m)

.判断循环尾 ()
画板1.写出 (“m=” + 到文本 (m) + “跳出循环”)

.子程序 _按钮3_被单击, , , 奇数
.局部变量 n, 整数型

.' 变量循环首 (1, 10, 2, n)
' 画板1.滚动写行 (n)
.' 变量循环尾 ()
.计次循环首 (10, n)
.如果真 (n % 2 = 0)
到循环尾 ()
.如果真结束

画板1.滚动写行 (n)
.计次循环尾 ()

.子程序 _按钮4_被单击, , , 偶数
.局部变量 n, 整数型

.' 变量循环首 (1, 10, 2, n)
' 画板1.滚动写行 (n + 1)
.' 变量循环尾 ()
.' 变量循环首 (2, 10, 2, n)
' 画板1.滚动写行 (n)
.' 变量循环尾 ()
.计次循环首 (10, n)
.如果真 (n % 2 ≠ 0)
到循环尾 ()
.如果真结束

画板1.滚动写行 (n)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: