易语言SHCreateThread创建扩展线程

SHCreateThread函数原型

BOOL SHCreateThread(
  LPTHREAD_START_ROUTINE pfnThreadProc,
  void                   *pData,
  SHCT_FLAGS             flags,
  LPTHREAD_START_ROUTINE pfnCallback
);

易语言

.版本 2
 
.DLL命令 创建扩展线程_, 整数型, "shlwapi.dll", "SHCreateThread", , SHCreateThread
    .参数 线程地址, 整数型, , pfnThreadProc
    .参数 数据, 整数型, , pData,Any
    .参数 标志, 整数型, , dwFlags
    .参数 返回信息, 整数型, , pfnCallback

易语言调用

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮_创建扩展线程_被单击
.局部变量 局部_标志变量, 整数型

局部_标志变量 = 0
创建扩展线程_ (到数值 (&子程序_线程1), 0, 局部_标志变量, 0)
创建扩展线程_ (到数值 (&子程序_线程2), 0, 局部_标志变量, 0)

.子程序 子程序_线程1

.判断循环首 (到数值 (标签_0.标题) < 10000)
标签_0.标题 = 到文本 (到数值 (标签_0.标题) + 1)
处理事件 ()
标签_0.刷新显示 ()
.判断循环尾 ()

.子程序 子程序_线程2

.判断循环首 (到数值 (标签_10000.标题) > 0)
标签_10000.标题 = 到文本 (到数值 (标签_10000.标题) - 1)
处理事件 ()
标签_10000.刷新显示 ()
.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: