第三课易语言大漠多线程绑定游戏和打怪

部分源码:

.版本 2
.支持库 EThread
 
.子程序 _按钮_开始多线程_被单击
.局部变量 total_array, 整数型
.局部变量 i, 整数型
.局部变量 hwnd, 整数型
 
进程_取ID数组 (“gamefree.exe”, process_id, )
total_array = 取数组成员数 (process_id)
.计次循环首 (total_array, i)
    初始化 (i)
    hwnd = 进程_ID取窗口句柄 (process_id [i], , , )
    BindWindow (hwnd, “dx”, “dx2”, “windows”, 0, i)
    延时 (500)
    dm_array = i
    启动线程 (&多线程, , )
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: