易语言随机生成MAC源码

易语言api hook GetAdaptersAddresses 劫持网卡物理地址

随机生成MAC源码:

.版本 2
.支持库 spec
 
.局部变量 i, 整数型
.局部变量 tmp, 字节型, , "20"
.局部变量 mac, 文本型, , "0"
.局部变量 n
.局部变量 文本, 文本型
置随机数种子 ()
.计次循环首 (6, n)
    .计次循环首 (2, i)
 
        tmp [i] = 取代码 (取文本中间 (“0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ”, 取随机数 (1, 36), 1), )
    .计次循环尾 ()
    加入成员 (mac, 到文本 (tmp))
.计次循环尾 ()
 
文本 = mac [1] + “-” + mac [2] + “-” + mac [3] + “-” + mac [4] + “-” + mac [5] + “-” + mac [6]
调试输出 (文本)

MAC效果

* “3B-YQ-T5-FM-OL-9R”
* “F3-ZW-JS-WX-I3-UQ”
* “YO-73-D1-R8-RW-OQ”
* “RZ-XO-TU-KN-C2-DJ”
* “WE-0J-MK-8L-G6-ZK”
* “ZM-Y1-JZ-7O-E9-6R”
* “HW-24-KR-F9-6F-DP”
* “UD-GH-ND-0R-NE-JL”
* “VZ-IA-8S-GD-OE-MN”
* “8Y-OT-O0-DB-WP-EZ”
* “B2-FK-PH-6I-JX-CX”
* “BA-MI-20-1U-R6-02

发布日期:

所属分类: 易语言 标签: