第四课易语言大漠多线程绑定和打怪(方法二)

部分源码:

.版本 2
.支持库 spec
 
.子程序 _按钮_thread_被单击
.局部变量 process_id, 整数型, , "0"
.局部变量 array_total, 整数型
.局部变量 i, 整数型
.局部变量 hwnd, 整数型
 
进程_取ID数组 (“gamefree.exe”, process_id, )
array_total = 取数组成员数 (process_id)
重定义数组 (dm,, array_total)
重定义数组 (thread_hwnd,, array_total)
重定义数组 (thread_ID,, array_total)
.计次循环首 (array_total, i)
    dm [i].初始化 ()
    hwnd = 进程_ID取窗口句柄 (process_id [i], , , )
    dm [i].BindWindow (hwnd, “dx”, “dx2”, “windows”, 0)
    延迟 (500)
    thread_hwnd [i] = 线程_启动 (&子程序_主线程, i, thread_ID [i])
    延迟 (500)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签:   


下一篇:

没有了,已经是最新文章