易语言读取系统内存信息

一、用到的API

.版本 2

.DLL命令 GlobalMemoryStatusEx, 整数型
.参数 lpBuffer, MemoryInfo, 传址

二、自定义数据类型
.版本 2

.数据类型 MemoryInfo
.成员 本结构长度, 整数型, , , dwLength
.成员 已使用的内存百分比, 整数型, , , dwMemoryLoad
.成员 物理内存总量, 长整数型, , , dwTotalphys
.成员 可用物理内存, 长整数型, , , dwAvailphys
.成员 交换文件总大小, 长整数型, , , dwTotalPageFile
.成员 交换文件空闲大小, 长整数型, , , dwAvailPageFile
.成员 用户可用的地址空间, 长整数型, , , dwTotalVirtual
.成员 当前空闲的地址空间, 长整数型, , , dwAvailVirtual

三、主程序
.版本 2

.程序集 窗口程序集1

.子程序 _时钟1_周期事件
.局部变量 N, MemoryInfo
.局部变量 K, 整数型

N.本结构长度 = 64
GlobalMemoryStatusEx (N)
标签1.标题 = “内存占用率:” + 到文本 (N.已使用的内存百分比) + “%” + #换行符 + #换行符 + “物理内存总量:” + 到文本 (四舍五入 (N.物理内存总量 ÷ 1024 ÷ 1024 ÷ 1024, 0)) + “GB ” + #换行符 + #换行符 + “可用内存大小:” + 到文本 (四舍五入 (N.可用物理内存 ÷ 1024 ÷ 1024 ÷ 1024, 1)) + “GB” + #换行符 + #换行符 + “虚拟内存总大小:” + 到文本 (N.用户可用的地址空间 ÷ 1024) + “MB” + #换行符 + #换行符 + “可用虚拟内存大小:” + 到文本 (N.当前空闲的地址空间) + “MB” + #换行符 + #换行符 + “交换文件总大小:” + 到文本 (N.交换文件总大小 ÷ 1024) + “MB”

.计次循环首 (取整 (N.已使用的内存百分比), K)
画板1.清除 (, , , )
画板1.画笔颜色 = 取颜色值 (10, 122, 100)
画板1.刷子颜色 = 取颜色值 (80, 189, 156)
画板1.画圆角矩形 (0, 0, 取整 (N.已使用的内存百分比) × 3, 12, 4, 4)
' 本源码来自易语言资源网(www.5A5X.com)
.计次循环尾 ()

.子程序 __启动窗口_创建完毕

时钟1.时钟周期 = 1000
画板1.清除 (, , , )

画板1.刷子颜色 = 取颜色值 (20, 244, 216)
画板1.画圆角矩形 (0, 12, 300, 12, 4, 4)


发布日期:

所属分类: 易语言 标签: