易语言教程取文件尺寸时间文件更名等实例

系统核心支持库-取文件尺寸、取文件时间、文件更名、文件是否存在、取临时文件、

新命令
1、文件更名()
2、文件是否存在()
3、取文件时间()
4、取文件尺寸()
5、取临时文件()
新组建
1、拖放对象
2、通用对话框

视频教程源码:

.版本 2
.支持库 edroptarget

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

拖放对象1.注册拖放控件 (编辑框1.取窗口句柄 ())

.子程序 _拖放对象1_得到文件
.参数 接收到的文件路径, 文本型

编辑框1.内容 = 接收到的文件路径

.子程序 _按钮1_被单击, , , 文件更名
.局部变量 返回值, 逻辑型

' 更改文件或目录名!!
返回值 = 文件更名 (编辑框1.内容, 编辑框2.内容)
.如果 (返回值 = 真)
信息框 (“更名成功!!!”, 0, , )
.否则
信息框 (“更名失败!!!”, 0, , )
.如果结束

.子程序 _按钮2_被单击, , , 文件是否存在
.局部变量 返回值, 逻辑型

返回值 = 文件是否存在 (编辑框1.内容)
.如果 (返回值 = 真)
编辑框2.内容 = “文件存在!!!”
信息框 (“文件存在!!!”, 0, , )
.否则
编辑框2.内容 = “文件不存在!!!”
信息框 (“文件不存在!!!”, 0, , )
.如果结束

.子程序 _按钮3_被单击, , , 取文件时间
.局部变量 ftime, 日期时间型

ftime = 取文件时间 (编辑框1.内容)
.如果 (到文本 (ftime) = “100年1月1日”)
编辑框2.内容 = “文件不存在!!”
信息框 (“文件不存在!!!”, 0, , )
.否则
编辑框2.内容 = “文件最后修改日期:” + 到文本 (ftime)
.如果结束

.子程序 _按钮4_被单击, , , 取文件尺寸
.局部变量 文件尺寸, 整数型

文件尺寸 = 取文件尺寸 (编辑框1.内容)
.如果 (文件尺寸 = -1)
编辑框2.内容 = “文件不存在!!”
信息框 (“文件不存在!!!”, 0, , )

.否则
编辑框2.内容 = “文件尺寸为:” + 到文本 (文件尺寸 ÷ 1024) + “ KB”
.如果结束

.子程序 _按钮5_被单击, , , 取文件尺寸-2--调用通用对话框
.局部变量 文件尺寸, 整数型

.如果真 (通用对话框1.打开 ())
文件尺寸 = 取文件尺寸 (通用对话框1.文件名)
编辑框2.内容 = “文件尺寸为:” + 到文本 (文件尺寸 ÷ 1024) + “ KB”
.如果真结束

.子程序 _按钮6_被单击, , , 取临时文件名

编辑框2.内容 = 取临时文件名 ()


发布日期:

所属分类: 易语言 标签: