511遇见易语言软件本地注册验证-20-RSA注册机客户端验证

课程提纲:

1、直接对注册码验证
2、导入注册文件.reg验证

RSA客户端源码:

.版本 2
.支持库 dp1
.支持库 spec

.程序集 窗口程序集_窗口1

.子程序 _窗口1_创建完毕

编辑框1.内容 = 到文本 (系统_取特征码综合 ())

.子程序 _按钮1_被单击
.局部变量 机器码, 文本型
.局部变量 用户名, 文本型
.局部变量 注册码, 文本型
.局部变量 公钥, 文本型
.局部变量 公共模数, 文本型

用户名 = 删首尾空 (编辑框2.内容)
.如果 (用户名 = “”)
信息框 (“请填写用户名!”, 0, , )
返回 ()

.否则

.如果结束
机器码 = 编辑框1.内容
注册码 = 删首尾空 (编辑框3.内容)
公钥 = “99371”
公共模数 = “588F8CA098392E136AA6C16B84698B6F23A03931B1CF1438FCAE3C70979774433113C55F0365990876C310CB6F9CA37F8775516EB500862F7B53D1E7C1B4CA4B33BA7A07AF2A038F68187FDA661CCDEA6F964B287EA36F56740F2832E6CE68F4D1FF8D45FC424B09C6D4E710DD75355748697E488AF72B0CC52C21060B855FF1”
.如果 (签名验证 (到字节集 (机器码 + 用户名), 注册码, 公钥, 公共模数))
是否注册 = 真
信息框 (“注册成功!”, 0, , )
.否则
是否注册 = 假
信息框 (“注册失败!”, 0, , )
.如果结束

调试输出 (是否注册)

.子程序 _按钮2_被单击

.如果 (编辑框2.内容 = “”)
信息框 (“请填写用户名!”, 0, , )
返回 ()

.否则

.如果结束
通用对话框1.文件名 = “reg” + 编辑框1.内容 + “.key”
.如果真 (通用对话框1.打开 ())
编辑框3.内容 = 到文本 (读入文件 (通用对话框1.文件名))
.如果真结束


发布日期:

所属分类: 易语言 标签: