易语言递归寻找文件及文件夹

寻找文件官方文档

调用格式: 〈无返回值〉 赋值 (通用型变量/变量数组 被赋值的变量或变量数组,通用型数组/非数组 用作赋于的值或资源) - 系统核心支持库->变量操作
英文名称:set
将指定的常数、常数集、常量、资源、对象或者变量赋于到指定的变量或变量数组中去。运算符号为“=”。本命令为初级命令。
参数<1>的名称为“被赋值的变量或变量数组”,类型为“通用型(all)”,提供参数数据时只能提供变量及变量数组。
参数<2>的名称为“用作赋于的值或资源”,类型为“通用型(all)”,提供参数数据时可以同时提供数组或非数组数据。

操作系统需求: Windows、Linux、Unix

-------------------
调用格式: 〈通用型〉 相加 (通用型 被加数或文本或字节集,通用型 加数或文本或字节集,... ) - 系统核心支持库->算术运算
英文名称:add
运算符号为“+”,用途为:1、返回两个数值的和;2、将两个文本首尾连接起来,返回连接后的文本;3、将两个字节集首尾连接起来,返回连接后的字节集。本命令为初级命令。命令参数表中最后一个参数可以被重复添加。
参数<1>的名称为“被加数或文本或字节集”,类型为“通用型(all)”。
参数<2>的名称为“加数或文本或字节集”,类型为“通用型(all)”。

操作系统需求: Windows、Linux、Unix

视频教程源码

.版本 2
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 寻找文件
.局部变量 目录, 文本型

列表框1.清空 ()
目录 = 浏览文件夹 (“请选择寻找文件的目录”, )
' F:\511遇见教程
.如果 (取文本右边 (目录, 1) ≠ “\”)
目录 = 目录 + “\”
.否则

.如果结束
编辑框1.内容 = 目录
查找文件或目录 (目录)

.子程序 查找文件或目录
.参数 文件夹, 文本型
.局部变量 文件, 文本型

处理事件 ()
.如果 (取文本右边 (文件夹, 1) ≠ “\”)
文件夹 = 文件夹 + “\”
.否则

.如果结束
' 默认为搜寻除子目录外的所有文件。第一次调用
文件 = 寻找文件 (文件夹 + “*.*”, )
.判断循环首 (文件 ≠ “”)
列表框1.加入项目 (文件夹 + 文件, )
' 再一次调用本命令,且不要提供欲寻找文件名参数,第二次调用
文件 = 寻找文件 (, )
.判断循环尾 ()
文件 = 寻找文件 (文件夹 + “*.*”, #子目录) ' 文件就变成了新的文件夹了
.判断循环首 (文件 ≠ “”)
.如果真 (文件 ≠ “.” 且 文件 ≠ “..”)
查找文件或目录 (文件夹 + 文件) ' 在寻找新的文件夹,递归的方法就是调用了自己本身

.如果真结束
文件 = 寻找文件 (, #子目录)
.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: