易语言教程数组操作数组排序

官方文档

调用格式: 〈无返回值〉 数组排序 (通用型变量数组 数值数组变量,[逻辑型 排序方向是否为从小到大]) - 系统核心支持库->数组操作
英文名称:SortAry
对指定数值数组变量内的所有数组成员进行快速排序,不影响数组的维定义信息,排序结果存放回该数组变量。本命令为初级命令。
参数<1>的名称为“数值数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。
参数<2>的名称为“排序方向是否为从小到大”,类型为“逻辑型(bool)”,可以被省略。如果参数值为真,排序方向为从小到大,否则为从大到小。如果本参数被省略,默认值为真。

操作系统需求: Windows、Linux

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 集_数组, 整数型, , "0"

.子程序 __启动窗口_创建完毕

.子程序 _按钮1_被单击, , , 初始化数组

初始化数组 ()

.子程序 初始化数组
.局部变量 m, 整数型
.局部变量 加数

置随机数种子 ()
编辑框1.内容 = “”
.计次循环首 (100, m)
加数 = 取随机数 (1, 100)
加入成员 (集_数组, 加数 + m)
编辑框1.加入文本 (到文本 (加数 + m) + #换行符)
.计次循环尾 ()

.子程序 _按钮2_被单击, , , 数组排序(小-大) 对指定数值数组变量内的所有数组成员进行快速排序,不影响数组的维定义信息,排序结果存放回该数组变量。
.局部变量 n, 整数型

数组排序 (集_数组, )
编辑框2.内容 = “”
调试输出 (集_数组)
.计次循环首 (取数组成员数 (集_数组), n)
编辑框2.加入文本 (到文本 (集_数组 [n]) + #换行符)
.计次循环尾 ()

.子程序 _按钮3_被单击, , , 数组排序(大-小)
.局部变量 n, 整数型

数组排序 (集_数组, 假)
编辑框2.内容 = “”
调试输出 (集_数组)
.计次循环首 (取数组成员数 (集_数组), n)
编辑框2.加入文本 (到文本 (集_数组 [n]) + #换行符)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: