易语言主程序调用DLL的图片资源

DLL自定义数据类型:

.版本 2
 
.数据类型 pic
    .成员 logo, 字节集
    .成员 ico, 字节集

DLL里的图片资源:

.版本 2
 
.图片 logo
.图片 ico

DLL函数方法源码:

.版本 2
 
.子程序 getlogo, , 公开
.参数 保存地址, 整数型
.局部变量 A, 字节集
 
A = #logo
交换变量数据_变量交地址ASM (A, 保存地址)
 
.子程序 mdll, , 公开
.参数 保存地址, 整数型
.局部变量 A, pic
 
A.logo#logo
A.ico#ico
交换变量数据_变量交地址ASM (A, 保存地址)

易语言动态调用DLL里的图片资源:

.版本 2
 
.子程序 _按钮1_被单击
.局部变量 a, 字节集
.局部变量 地址
.局部变量 命令地址
.局部变量 参数数据地址, , , "1"
 
地址 = 取变量地址_ASM (a)
命令地址 = 取DLL命令地址_ASM (dll路径, “getlogo”)
参数数据地址 [1] = 地址
调用命令_ASM (命令地址, 参数数据地址, )
图片框1.图片 = a
 
.子程序 _按钮2_被单击
.局部变量 a, pic
.局部变量 地址
.局部变量 命令地址
.局部变量 参数数据地址, , , "1"
 
地址 = 取变量地址_ASM (a)
命令地址 = 取DLL命令地址_ASM (dll路径, “mdll”)
参数数据地址 [1] = 地址
调用命令_ASM (命令地址, 参数数据地址, )
图片框1.图片 = a.logo
图标 = a.ico

易语言动静态调用DLL里的图片资源:

.版本 2
 
.子程序 _按钮1_被单击, , , 主程序
.局部变量 a, 字节集
.局部变量 变量地址, 整数型
 
变量地址 = 取变量地址_ASM (a)
getlogo (变量地址)
图片框1.图片 = a
 
.子程序 _按钮2_被单击
.局部变量 a, pic
.局部变量 变量地址, 整数型
 
变量地址 = 取变量地址_ASM (a)
mdll (变量地址)
图片框1.图片 = a.logo
图标 = a.ico

教程下载:


发布日期:

所属分类: 易语言 标签: