易语言api hook DestroyWindow禁止关闭窗口

DestroyWindow

.版本 2
 
.DLL命令 DestroyWindow, 逻辑型, "user32", "DestroyWindow"
    .参数 hWnd, 整数型, , 0

hook

.版本 2
 
.子程序 hook
 
.如果 (h.安装Hook (“user32.dll”, “DestroyWindow”, 到整数 (&mydw)) = 真)
    信息框 (“Hook成功!!”, 0, , )
    h.开始Hook ()
.否则
    信息框 (“Hook失败!!”, 0, , )
    h.卸载Hook ()

回调

.版本 2
 
.子程序 mydw
.参数 hwnd, 整数型
 
.判断开始 (hwnd ≠ 0)
    信息框 (“关闭已经被劫持,你无法关闭窗口”, 0, , )
 
.默认
    hook ()

子窗口关闭按键

  1. .版本 2
  2.  
  3. .子程序 _超级按钮1_被单击
  4.  
  5. DestroyWindow (窗口2.取窗口句柄 ())

注入方式

我们也可以通过注入方式来实现,本课视频演示采用了EIP注入和远程线程注入。

.版本 2
 
hook ()
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
.子程序 hook, , 公开
 
.如果 (h.安装Hook (“user32.dll”, “DestroyWindow”, 到整数 (&mydw)) = 真)
    信息框 (“Hook成功!!”, 0, , )
    h.开始Hook ()
.否则
    信息框 (“Hook失败!!”, 0, , )
    h.卸载Hook ()
.如果结束
 
.子程序 mydw
.参数 hwnd, 整数型
 
.判断开始 (hwnd ≠ 0)
    信息框 (“关闭已经被劫持,你无法关闭窗口”, 0, , )
 
.默认
    hook ()

教程获取下载:


发布日期:

所属分类: 易语言 标签: