大漠多线程循环任务自动切换模板-3一键开启和关闭游戏

一键启动和关闭游戏源码:

.版本 2
.支持库 iext
 
.子程序 _按钮_开启游戏_被单击, , , 开启游戏
.局部变量 游戏路径, 文本型
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 m, 整数型
.局部变量 局_句柄, 整数型, , "0"
 
游戏路径 = “D:\游戏\剑侠\剑侠情缘网络版\gamefree.exe”
.计次循环首 (窗口列表.取表项数 (), )
    进程_创建 (游戏路径, )
    超级延时 (1000, )
.计次循环尾 ()
进程_取ID数组 (“gamefree.exe, 进程ID数组, )
重定义数组 (局_句柄,, 取数组成员数 (进程ID数组))
.计次循环首 (取数组成员数 (进程ID数组), m)
    局_句柄 [m] = 进程_ID取窗口句柄 (进程ID数组 [m], , , )
    窗口列表.置标题 (m - 1, 3, 到文本 (局_句柄 [m]))
.计次循环尾 ()
按钮_开始.禁止 = 假
按钮_关闭.禁止 = 假
按钮_开启游戏.禁止 = 真
 
.子程序 _按钮_关闭_被单击, , , 关闭所有游戏窗口
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 n, 整数型
 
进程_取ID数组 (“gamefree.exe, 进程ID数组, )
.计次循环首 (取数组成员数 (进程ID数组), n)
    进程_结束 (进程ID数组 [n])
.计次循环尾 ()
窗口列表.全部删除 ()
按钮_开启游戏.禁止 = 假


发布日期:

所属分类: 易语言 标签: