大漠多线程循环任务自动切换模板-6脚本主线程控制

脚本主线程控制源码:

.版本 2
.支持库 iext
 
.子程序 主线程, , , 脚本的主要控制
.参数 索引, 整数型
 
' 初始化一下提交次数和完成账号
窗口列表.置标题 (索引 - 1, 5, “”)
窗口列表.置标题 (索引 - 1, 7, “”)
.判断循环首 (线程 [索引].运行状态 > 0)
    ' 第一个跳出判断
    .判断开始 (到整数 (窗口列表.取标题 (索引 - 1, 7)) ≥ 到整数 (窗口列表.取标题 (索引 - 1, 6)))
        监控反馈 (索引, “本窗口全部完成”)
        跳出循环 ()
 
    .判断 (窗口列表.取标题 (索引 - 1, 1) = “”)  ' 涉及账号切换
        监控反馈 (索引, “切换账号”)
        切换账号 (索引)
    .默认
 
    .判断结束
    ' ----------下面就是游戏脚本的环节
    监控反馈 (索引, “登录游戏”)
    登录游戏 (索引)
    监控反馈 (索引, “开始打怪”)
    模拟打怪 (索引)
    监控反馈 (索引, “退出游戏”)
    退出游戏 (索引)
 
    ' 清空一下当前账号提交次数
    窗口列表.置标题 (索引 - 1, 5, “”)
    ' 清空完成账号的测试
    窗口列表.置标题 (索引 - 1, 7, 到文本 (到整数 (窗口列表.取标题 (索引 - 1, 7))1))
    ' 清空一下当前的账号
    窗口列表.置标题 (索引 - 1, 1, “”)
    ' 反馈完成
    监控反馈 (索引, “全部完成”)
 
.判断循环尾 ()
' 解除线程的绑定
线程 [索引].dm.UnBindWindow ()
' 还原窗口状态
线程 [索引].dm.SetWindowState (到整数 (窗口列表.取标题 (索引 - 1, 3)), 5)
' ------------再次绑定下一个窗口
线程 [索引].dm.SetWindowState (到整数 (窗口列表.取标题 (索引 - 1, 3)), 1)
' 后台绑定
线程 [索引].dm.BindWindow (到整数 (窗口列表.取标题 (索引 - 1, 3)), “dx”, “dx2”, “windows”, 0)
线程 [索引].dm.DownCpu (40)


发布日期:

所属分类: 易语言 标签: