第九课易语言大漠剑侠情缘多线程木人巷对话NPC

木人巷对话NPC源码:

.版本 2
.支持库 iext
 
.子程序 皇城司提点官, , , 4
.参数 数组序号, 整数型
.局部变量 文本, 文本型
.局部变量 文本数组, 文本型, , "0"
.局部变量 文本1, 文本型
.局部变量 文本数组1, 文本型, , "0"
.局部变量 文本2, 文本型
.局部变量 文本数组2, 文本型, , "0"
.局部变量 i, 整数型
 
超级列表框1.置标题 (数组序号 - 1, 4, “对话皇城司提点官”)
i = 1
.判断循环首 (i = 1)
    处理事件 ()
    延时 (300)
    文本1 = FindStrFastE (0, 0, 800, 600, “提点官”, “ffffff-000000, 1, 数组序号)
    延时 (300)
    文本数组1 = 分割文本 (文本1,|, )
    延时 (300)
    .如果 (到整数 (文本数组1 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组1 [2]), 到整数 (文本数组1 [3])70, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        i = 0
        跳出循环 ()
 
    .否则
        i = 1
    .如果结束
 
    延时 (300)
    文本 = FindStrFastE (0, 0, 800, 600, “统领”, “ffffff-000000, 1, 数组序号)
    延时 (300)
    文本数组 = 分割文本 (文本,|, )
    延时 (300)
    .如果 (到整数 (文本数组 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组 [2])345, 到整数 (文本数组 [3])106, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        i = 0
        跳出循环 ()
 
    .否则
        i = 1
    .如果结束
    延时 (300)
    文本2 = FindStrFastE (0, 0, 800, 600, “皇宫”, “ffffff-000000, 1, 数组序号)
    延时 (300)
    文本数组2 = 分割文本 (文本2,|, )
    延时 (300)
    .如果 (到整数 (文本数组2 [1])0)
        延时 (300)
        MoveTo (到整数 (文本数组2 [2])255, 到整数 (文本数组2 [3])83, 数组序号)
        延时 (300)
        LeftClick (数组序号)
        i = 0
        跳出循环 ()
 
    .否则
        i = 1
    .如果结束
    跳出循环 ()
.判断循环尾 ()


发布日期:

所属分类: 易语言 标签: