易语言NetGetJoinInformation取本机工作组名称类型

用到的API

.版本 2
 
.DLL命令 取本机工作组信息_, 整数型, "Netapi32.dll", "NetGetJoinInformation"
    .参数 本机名称, 整数型, , lpServer,易语言中给0
    .参数 工作组名称, 整数型, 传址, lpNameBuffer
    .参数 工作组类型, 整数型, 传址, BufferType
 
.DLL命令 取字节长度_, 整数型, "kernel32.dll", "lstrlenW"
    .参数 待取参数, 整数型, , any
 
.DLL命令 释放指定内存_, 整数型, "netapi32.dll", "NetApiBufferFree"
    .参数 缓冲区, 整数型, , Buffer
 
.DLL命令 双字节到宽字符_, 整数型, "SHLWAPI", "#217", , SHUnicodeToAnsi
    .参数 双字节文本, 字节集, 传址, lpMultiBVytestyr
    .参数 宽字符文本, 文本型, , lpWideCharStr
    .参数 宽字符文本长度, 整数型, , cchWideChar

子程序_取地址文本

.版本 2

.子程序 子程序_取地址文本, 文本型
.参数 参数_指针地址, 整数型
.局部变量 局部_双字文本, 字节集
.局部变量 局部_变量长度, 整数型
.局部变量 局部_宽字符文本, 文本型
.局部变量 局部_宽字符文本长度, 整数型

局部_变量长度 = 取字节长度_ (参数_指针地址) × 4
局部_双字文本 = 指针到字节集 (参数_指针地址, 局部_变量长度)
局部_宽字符文本长度 = 取字节集长度 (局部_双字文本) + 1
局部_宽字符文本 = 取空白文本 (局部_宽字符文本长度 - 1)
双字节到宽字符_ (局部_双字文本, 局部_宽字符文本, 局部_宽字符文本长度)
返回 (删全部空 (局部_宽字符文本))

调用

.版本 2
 
.子程序 _按钮_取本机工作组信息_被单击
.局部变量 局部_是否成功, 整数型
.局部变量 局部_工作组名称, 整数型
.局部变量 局部_工作组类型, 整数型
 
连续赋值 (0, 局部_工作组名称, 局部_工作组类型)
局部_是否成功 = 取本机工作组信息_ (0, 局部_工作组名称, 局部_工作组类型)
.如果真 (局部_是否成功 = 0)
    编辑框_名称.内容 = 子程序_取地址文本 (局部_工作组名称)
    编辑框_类型.内容 = 子程序_取工作组状态 (局部_工作组类型)
.如果真结束
释放指定内存_ (局部_工作组名称)

发布日期:

所属分类: 易语言 标签: