易语言PathMakeSystemFolderA设置目录系统属性

设置目录系统属性

.版本 2
 
.DLL命令 设置目录系统属性_, 整数型, "shlwapi.dll", "PathMakeSystemFolderA"
    .参数 目录, 文本型, , pszPath

目录是否系统属性

.版本 2
 
.DLL命令 目录是否系统属性_, 整数型, "shlwapi.dll", "PathIsSystemFolderA"
    .参数 目录, 文本型, , pszPath
    .参数 属性标志, 整数型, 传址, dwAttrb

取消目录系统属性

.版本 2
 
.DLL命令 取消目录系统属性_, 整数型, "shlwapi.dll", "PathUnmakeSystemFolderA"
    .参数 目录, 文本型, , pszPath

调用示范

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

创建目录 (“c:\test”)

.子程序 子程序_设置系统属性, 逻辑型

.判断开始 (编辑框_目录.内容 ≠ “”)
.判断开始 (设置目录系统属性_ (编辑框_目录.内容) ≠ 0)
返回 (真)
.默认
返回 (假)
.判断结束

.默认
返回 (假)
.判断结束

.子程序 子程序_取消系统属性, 逻辑型

.判断开始 (编辑框_目录.内容 ≠ “”)
.判断开始 (取消目录系统属性_ (编辑框_目录.内容) ≠ 0)
返回 (真)
.默认
返回 (假)
.判断结束

.默认
返回 (假)
.判断结束

.子程序 子程序_检查系统属性, 逻辑型

.判断开始 (编辑框_目录.内容 ≠ “”)
.判断开始 (目录是否系统属性_ (编辑框_目录.内容, 0) ≠ 0)
返回 (真)
.默认
返回 (假)
.判断结束

.默认
返回 (假)
.判断结束

.子程序 _按钮_目录是否系统属性_设置目录系统属性_被单击

.判断开始 (子程序_设置系统属性 () = 真)
标签_提示1.标题 = “设置成功”
.默认
标签_提示1.标题 = “设置失败”
.判断结束

.子程序 _按钮_目录是否系统属性_取消目录系统属性_被单击

.判断开始 (子程序_取消系统属性 () = 真)
标签_提示2.标题 = “取消成功”
.默认
标签_提示2.标题 = “取消失败”
.判断结束

.子程序 _按钮_目录是否系统属性_被单击

.判断开始 (子程序_检查系统属性 () = 真)
标签_提示3.标题 = “系统属性”
.默认
标签_提示3.标题 = “非系统属性”
.判断结束

.子程序 __启动窗口_将被销毁

子程序_取消系统属性 () ' 如果不取消系统属性将删除失败。
.如果真 (删除目录 (“c:\test”))
信息框 (“临时目录‘c:\test’已经成功删除”, 0 + #信息图标, “删除成功”)
.如果真结束


发布日期:

所属分类: 易语言 标签: