易语言永久修改窗口标题

修改窗口标题

.版本 2

.子程序 _按钮1_被单击
.局部变量 文件字节集, 字节集
.局部变量 标题位置, 整数型
.局部变量 补空字节集, 字节集
.局部变量 原来长度, 整数型
.局部变量 改后长度, 整数型

文件字节集 = 读入文件 (编辑框_程序地址.内容)
标题 = 到文本 (文件字节集)
标题位置 = 寻找字节集 (文件字节集, 到字节集 (编辑框_原来标题.内容), )
原来长度 = 取字节集长度 (到字节集 (编辑框_原来标题.内容))
改后长度 = 取字节集长度 (到字节集 (编辑框_改后标题.内容))
补空字节集 = 取空白字节集 (原来长度 - 改后长度)
文件字节集 = 字节集替换 (文件字节集, 标题位置, 原来长度, 到字节集 (编辑框_改后标题.内容) + 补空字节集)
写到文件 (编辑框_程序地址.内容, 文件字节集)


发布日期:

所属分类: 易语言 标签: