易语言全局键盘钩子两种方法实现窗口的隐藏显示

单键钩子安装

键盘钩子 = SetWindowsHookExA (13, &单键显示隐藏, GetModuleHandleA (0), 0)

单键显示隐藏结构体

.版本 2
 
.子程序 单键显示隐藏, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.参数 参数三, 整数型
.局部变量 键值, 整数型
 
键值 = 取字节集数据 (指针到字节集 (参数三, 1), 3, )
 
.判断开始 (参数二 = 256)
    .判断开始 (键值 = #Q)
        返回 (1)
    .默认
 
    .判断结束
 
.判断 (参数二 = 257)
    .判断开始 (键值 = #Q)
        .判断开始 (可视 = 真)
            可视 = 假
        .默认
            可视 = 真
        .判断结束
        返回 (1)
    .默认
 
    .判断结束
 
.默认
 
.判断结束
 
返回 (CallNextHookEx (键盘钩子, 参数一, 参数二, 参数三))

卸载键盘钩子

UnhookWindowsHookEx (键盘钩子)

双键显示隐藏窗口安装钩子

键盘钩子 = SetWindowsHookExA (13, &双键显示隐藏, GetModuleHandleA (0), 0)

双键显示隐藏回调函数

.版本 2
 
.子程序 双键显示隐藏, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.参数 参数三, 整数型
.局部变量 键值, 整数型
 
键值 = 取字节集数据 (指针到字节集 (参数三, 1), 3, )
' hide
.判断开始 (参数二 = 256)
    .判断开始 (键值 = #H键)
        ShowWindow (_启动窗口.取窗口句柄 (), 0)
        返回 (1)
    .默认
 
    .判断结束
 
.判断 (参数二 = 257)
    .判断开始 (键值 = #K键)
        ShowWindow (_启动窗口.取窗口句柄 (), 1)
    .默认
 
    .判断结束
.默认
.判断结束
返回 (CallNextHookEx (键盘钩子, 参数一, 参数二, 参数三))

卸载键盘钩子

UnhookWindowsHookEx (键盘钩子)

发布日期:

所属分类: 易语言 标签: