易语言教程-取操作系统类别

511遇见

视频教程源码:

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
.局部变量 ProductName, 文本型
.局部变量 ProductNumber, 整数型
 
ProductNumber = 取操作系统类别 ()
.判断开始 (ProductNumber = 0)
    ProductName = “未知”
.判断 (ProductNumber = 1)
    ProductName = “Windows 32S”
.判断 (ProductNumber = 2)
    ProductName = “Windows 9X (包含Win95、Win98、WinME等)”
.判断 (ProductNumber = 3)
    ProductName = “Windows NT (包含WinNT、Win2000、WinXP等)”
.判断 (ProductNumber = 4)
    ProductName = “Linux”
.默认
 
.判断结束
' 0、未知; 1、Windows 32S; 2、Windows 9X (包含Win95、Win98、WinME等); 3、Windows NT (包含WinNT、Win2000、WinXP等); 4、Linux。本命令为初级命令。
编辑框1.内容 = ProductName
 
.子程序 _按钮2_被单击
.局部变量 ProductName, 文本型
.局部变量 ProductNumber, 整数型
 
ProductNumber = 取操作系统类别2 ()
.判断开始 (ProductNumber = 0)
    ProductName = “未知”
.判断 (ProductNumber = 1)
    ProductName = “Windows 32S”
.判断 (ProductNumber = 2)
    ProductName = “Windows 9X (包含Win95、Win98、WinME等)”
.判断 (ProductNumber = 3)
    ProductName = “其它Windows NT操作系统(不包括后面列出的)”
.判断 (ProductNumber = 4)
    ProductName = “Linux”
.判断 (ProductNumber = 5)
    ProductName = “Windows 10”
.判断 (ProductNumber = 6)
    ProductName = “Windows Server 2016 Technical Preview”
.判断 (ProductNumber = 7)
    ProductName = “Windows 8.1”
.判断 (ProductNumber = 8)
    ProductName = “Windows Server 2012 R2”
.判断 (ProductNumber = 9)
    ProductName = “Windows 8”
.判断 (ProductNumber = 10)
    ProductName = “Windows Server 2012”
.判断 (ProductNumber = 11)
    ProductName = “Windows 7”
.判断 (ProductNumber = 12)
    ProductName = “Windows Server 2008 R2”
.判断 (ProductNumber = 13)
    ProductName = “Windows Server 2008”
.判断 (ProductNumber = 14)
    ProductName = “Windows Vista”
.默认
 
.判断结束
' 0、未知; 1、Windows 32S; 2、Windows 9X (包含Win95、Win98、WinME等); 3、其它Windows NT操作系统(不包括后面列出的); 4、Linux; 5、Windows 10; 6、Windows Server 2016 Technical Preview; 7、Windows 8.1; 8、Windows Server 2012 R2; 9、Windows 8; 10、Windows Server 2012; 11、Windows 7; 12、Windows Server 2008 R2; 13、Windows Server 2008; 14、Windows Vista。
编辑框1.内容 = ProductName
 
.子程序 _按钮3_被单击
 
取操作系统名称 ()
 
.子程序 取操作系统名称, 文本型
.局部变量 ProductName, 文本型
 
ProductName = 取文本注册项 (#本地机器, “SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProductName”, )
.如果真 (寻找文本 (ProductName, “10”, , 假) ≠ -1)
    ProductName = “Win 10”
.如果真结束
.如果真 (寻找文本 (ProductName, “8.1”, , 假) ≠ -1)
    ProductName = “Win 8.1”
.如果真结束
.如果真 (寻找文本 (ProductName, “7”, , 假) ≠ -1)
    ProductName = “Win 7”
.如果真结束
.如果真 (寻找文本 (ProductName, “XP”, , 假) ≠ -1)
    ProductName = “Win XP”
.如果真结束
 
编辑框1.内容 = ProductName
返回 (ProductName)


发布日期:

所属分类: 易语言 标签: