511遇见易语言多线程大漠多线程-14Api封装线程启动优先权设置

线程启动-设置优先级

1、SetThreadPriority
2、ResumeThread

模块源码:

.子程序 线程_启动_优先权, 整数型, 公开, 返回线程句柄,必须用 线程_关闭_句柄()关闭这个句柄
.参数 要启动的子程序, 子程序指针, , 要启动的子程序
.参数 要传去子程序的参数, 整数型, 可空, 往子程序传递一个整数型参数
.参数 不立即执行, 逻辑型, 可空, 是否立即执行,默认为空立即执行,不立即执行的话,ResumeThread线程_恢复
.参数 线程优先级, 整数型, 可空, 2,-1,0,-2,1,15,-15数字越大,优先级别越高,建议选择 1
.局部变量 hThread, 整数型
.局部变量 线程ID, 整数型

hThread = CreateThread (0, 0, 要启动的子程序, 要传去子程序的参数, 选择 (不立即执行, 4, 0), 线程ID)
.如果真 (线程优先级 ≠ 0)
SetThreadPriority (hThread, 线程优先级)
.如果真结束

返回 (hThread)


发布日期:

所属分类: 易语言 标签: