易语言组合框项目数值关联列表项目组合框计算器

教程截图

511遇见

组合框项目数值关联列表项目组合框源码:

.版本 2
 
.局部变量 要找的项目数值
.局部变量 m, 整数型
.局部变量 项目数值
.局部变量 项目文本, 文本型
 
要找的项目数值 = 到整数 (编辑框1.内容)
编辑框2.内容 = “”
.计次循环首 (组合框1.取项目数 (), m)
    项目数值 = 组合框1.取项目数值 (m - 1)
    .如果真 (项目数值 = 要找的项目数值)
        项目文本 = 组合框1.取项目文本 (m - 1)
        组合框1.选择 (项目文本)
        编辑框2.内容 = 项目文本
    .如果真结束
 
.计次循环尾 ()

计算器视频教程

.版本 2
 
.局部变量 a
.局部变量 b
.局部变量 c, 双精度小数型
.局部变量 运算, 文本型
 
运算 = 组合框1.取项目文本 (组合框1.现行选中项)
 
a = 到数值 (编辑框1.内容)
b = 到数值 (编辑框2.内容)
 
.判断开始 (运算 = “+)
    c = a + b
.判断 (运算 = “-”)
    c = a - b
.判断 (运算 = “*)
    c = a × b
.判断 (运算 = “/”)
    c = a ÷ b
.默认
 
.判断结束
编辑框3.内容 = 到文本 (c)

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: