易语言组合框读取写配置文件和列表项目

教程截图

易语言组合框

易语言组合框

组合框读取写配置文件和列表项目视频教程源码:

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
.局部变量 ini路径, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 n, 整数型
 
ini路径 = 取运行目录 () + “\data.ini”
组合框1.清空 ()
文本 = 分割文本 (读配置项 (ini路径, “系统数据”, “用户数据”, ), “|”, )
.计次循环首 (取数组成员数 (文本), n)
    组合框1.加入项目 (文本 [n], )
.计次循环尾 ()
 
.子程序 _按钮1_被单击
.局部变量 ini保存路径, 文本型
.局部变量 i, 整数型
.局部变量 文本, 文本型
 
ini保存路径 = 取运行目录 () + “\data_copy.ini”
.计次循环首 (组合框1.取项目数 (), i)
    文本 = 文本 + 组合框1.取项目文本 (i - 1) + “|”
.计次循环尾 ()
写配置项 (ini保存路径, “系统数据”, “用户数据”, 文本)
 
.子程序 _按钮2_被单击
 
写到文件 (取运行目录 () + “\列表项目”, 组合框2.列表项目)
 
.子程序 _按钮3_被单击
 
组合框3.列表项目 = 读入文件 (取运行目录 () + “\列表项目”)

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: