第五课 511遇见易语言大漠找字FindStrE系列

1、FindStr

.版本 2
.支持库 dm
dm_ret = dm.FindStr (713, 129, 754, 173, “寻”, “002222-000000”, 1, intX, intY)
.如果真 (intX ≥ 0 且 intY ≥ 0)
    dm.MoveTo (intX, intY)
    dm.LeftClick ()

2、FindStrE

.版本 2
.支持库 dm
.局部变量 POS, 文本型
.局部变量 POSZ, 文本型, , "0"
.局部变量 x, 整数型
.局部变量 y, 整数型
POS = dm.FindStrE (713, 129, 754, 173, “寻”, “002222-000000”, 1)
POSZ = 分割文本 (POS, “|”, )
.如果真 (到整数 (POSZ [1]) ≥ 0)
    x = 到整数 (POSZ [2])
    y = 到整数 (POSZ [3])
    dm.MoveTo (x, y)
    dm.LeftClick ()
.如果真结束

3、FindStrFast

.版本 2
.支持库 dm
.局部变量 dm_ret, 整数型
.局部变量 intX, 整数型
.局部变量 intY, 小数型
dm_ret = dm.FindStrFast (713, 129, 754, 173, “寻”, “002222-000000”, 1, intX, intY)
.如果真 (intX ≥ 0 且 intY ≥ 0)
    dm.MoveTo (intX, intY)
    dm.LeftClick ()

4、FindStrFastE

.版本 2
.支持库 dm
.局部变量 pos, 文本型
.局部变量 posz, 文本型, , "0"
.局部变量 intX, 整数型
.局部变量 intY, 小数型
pos = dm.FindStrFastE (713, 129, 754, 173, “寻”, “002222-000000”, 1)
posz = 分割文本 (pos, “|”, )
.如果真 (到整数 (posz [1]) ≥ 0)
    intX = 到整数 (posz [2])
    intY = 到整数 (posz [3])
    dm.MoveTo (intX, intY)
    dm.LeftClick ()

发布日期:

所属分类: 易语言 标签: