第15课 易语言CallWindowProcA动态调用dll及子程序

CallWindowProcA动态调用dll及子程序源码

.版本 2
 
.子程序 测试
.参数 hwnd, 文本型
.参数 msg, 整数型
.参数 wParam, 整数型
.参数 lParam, 整数型
 
信息框 (hwnd, 0, , )
 
.子程序 _按钮11_被单击
CallWindowProcA (到整数 (&测试), “我模仿DLL传递调用callwindowprocA”, 0, 0, “”)

dll源码:

.版本 2
.支持库 spec
 
.程序集 程序集1
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
 
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 add, 整数型, 公开
.参数 x, 整数型
.参数 y, 整数型
.参数 z, 整数型
 
返回 (x + y + z)
 
.子程序 sub, 整数型, 公开
.参数 x, 整数型
.参数 y, 整数型
 
返回 (x - y)
 
.子程序 mybox, , 公开
.参数 text, 文本型
 
信息框 (text, 0, , )
 
.子程序 myboxT, 文本型, 公开, --调用子程序使用
.局部变量 文本, 文本型
 
文本 = “我是DLL里的文本资源”
返回 (文本)
 
.子程序 myboxC, 整数型, 公开, --Call汇编调用
.参数 保存地址, 整数型
.局部变量 文本, 文本型
 
文本 = “我是DLL里的文本资源”
保存地址 = 取变量数据地址 (文本)
返回 (保存地址)
 
 
.子程序 adda, 整数型, 公开
.参数 x, 整数型
.参数 y, 整数型
.参数 z, 整数型
.参数 k, 文本型
 
返回 (x + y + z + 到整数 (k))


发布日期:

所属分类: 易语言 标签: