第12课 易语言动态调用dll及子程序-1


1、LoadLibraryA
2、GetProcAddress
3、FreeLibrary
4、调用子程序()

易语言动态调用dll及子程序教程源码:

.版本 2
.支持库 spec
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' 与DLL进行通信
' 1、调用DLL里面的方法资源
' 2、传递一些参数到DLL
 
.子程序 _按钮1_被单击
.局部变量 hadress, 整数型
.局部变量 返回值
.局部变量 Dhwnd
 
Dhwnd = LoadLibraryA (取运行目录 () + “\dll.dll”)
.如果真 (Dhwnd = 0)
    信息框 (“加载DLL失败”, 0, , )
    返回 ()
.如果真结束
调试输出 (Dhwnd)
 
hadress = GetProcAddress (Dhwnd, “add”)
.如果真 (hadress = 0)
    信息框 (“获取接口地址失败”, 0, , )
    返回 ()
.如果真结束
 
调试输出 (hadress)
' 怎么样来执行这个 add函数方法???
' 调用子程序()
.如果真 (调用子程序 (hadress, , 返回值, 到整数 (编辑框1.内容), 到整数 (编辑框2.内容), 到整数 (编辑框3.内容)))
    信息框 (返回值, 0, , )
.如果真结束
 
FreeLibrary (Dhwnd)
 
 
.子程序 _按钮2_被单击
.局部变量 hadress, 整数型
.局部变量 返回值
.局部变量 Dhwnd
 
Dhwnd = LoadLibraryA (取运行目录 () + “\dll.dll”)
.如果真 (Dhwnd = 0)
    信息框 (“加载DLL失败”, 0, , )
    返回 ()
.如果真结束
 
调试输出 (Dhwnd)
 
hadress = GetProcAddress (Dhwnd, “sub”)
.如果真 (hadress = 0)
    信息框 (“获取接口地址失败”, 0, , )
    返回 ()
.如果真结束
 
调试输出 (hadress)
' 怎么样来执行这个 add函数方法???
' 调用子程序()
调用子程序 (hadress, , 返回值, 到整数 (编辑框1.内容), 到整数 (编辑框2.内容))
信息框 (返回值, 0, , )
FreeLibrary (Dhwnd)


发布日期:

所属分类: 易语言 标签: