第13课 易语言动态调用dll及子程序2

易语言动态调用dll及子程序2教程源码:

.版本 2
.支持库 spec
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' 与DLL进行通信
' 1、调用DLL里面的方法资源
' 2、传递一些参数到DLL
 
.子程序 _按钮1_被单击, , , 求和
.局部变量 返回值
.局部变量 模块句柄
.局部变量 函数地址
 
函数地址 = 装载DLL (取运行目录 () + “\dll.dll”, “add”, 模块句柄)
.如果真 (模块句柄 ≠ -1)
    调用子程序 (函数地址, , 返回值, 到整数 (编辑框1.内容), 到整数 (编辑框2.内容), 到整数 (编辑框3.内容))
    信息框 (返回值, 0, , )
 
.如果真结束
 
释放DLL (模块句柄)
 
.子程序 _按钮2_被单击, , , 求差
.局部变量 返回值
.局部变量 模块句柄
.局部变量 函数地址
 
函数地址 = 装载DLL (取运行目录 () + “\dll.dll”, “sub”, 模块句柄)
.如果真 (模块句柄 ≠ -1)
    调用子程序 (函数地址, , 返回值, 到整数 (编辑框1.内容), 到整数 (编辑框2.内容))
    信息框 (返回值, 0, , )
 
.如果真结束
 
释放DLL (模块句柄)
 
 
.子程序 _按钮3_被单击, , , 传递文本
.局部变量 Dhwnd
.局部变量 函数地址
 
函数地址 = 装载DLL (取运行目录 () + “\dll.dll”, “mybox”, Dhwnd)
.如果真 (Dhwnd ≠ -1)
    调用子程序 (函数地址, , , “我是程序里的文本,传递到DLL的参数里的。”)
 
.如果真结束
 
释放DLL (Dhwnd)


发布日期:

所属分类: 易语言 标签: