易语言eip注入DLL到游戏

511遇见

eip注入DLL调用

.版本 2
 
.子程序 _按钮1_被单击
.局部变量 bool, 逻辑型
 
bool = EIP_注入 (到整数 (编辑框1.内容), 编辑框2.内容)
.如果 (bool = 真)
    信息框 (“EIP注入成功”, 0, , )
 
.否则
    信息框 (“EIP注入失败!”, 0, , )
.如果结束

注入DLL源码:

.版本 2
 
.程序集 程序集1
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
eip ()
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
 
.子程序 eip, , 公开
 
载入 (窗口1, , 真)

教程获取下载:


发布日期:

所属分类: 易语言 标签: