易语言删除指定数组里的成员三种方法

方法一:

窗口程序集名 保 留   保 留 备 注 
窗口程序集1       
子程序名 返回值类型 公开 备 注 
_按钮1_被单击      
变量名 类 型 静态 数组 备 注 
数组 整数型   0  
成员数 整数型      
计次 整数型      
加入成员 (数组, 1)
加入成员 (数组, 0)
加入成员 (数组, 1)
加入成员 (数组, 0)
加入成员 (数组, 0)
加入成员 (数组, 1)
成员数 = 取数组成员数 (数组)
计次循环首 (成员数, 计次)
如果真 (数组 [成员数 - 计次 + 1]0)  ' 从最后一个开始 往前
删除成员 (数组, 成员数 - 计次 + 1, 1)
 
计次循环尾 ()
调试输出 (数组)

方法2:

版本 2
.支持库 spec
 
加入成员 (arr, 0)
加入成员 (arr, 1)
加入成员 (arr, 2)
加入成员 (arr, 0)
加入成员 (arr, 3)
i = 取数组成员数 (arr)
n = 1
.判断循环首 (i ≥ n)
 
    .如果 (arr [n]0)
        删除成员 (arr, n, )
        i = 取数组成员数 (arr)
        n = 1
        调试输出 (i, n)
    .否则
 
    .如果结束
    n = n + 1
.判断循环尾 ()

方法3传递参数:

.版本 2
.支持库 spec
 
.子程序 删除数组成员
.参数 参_name, 文本型
.局部变量 计次, 整数型
.局部变量 total, 整数型, , , 数组成员总和
.局部变量 i, 整数型
.局部变量 n, 整数型
 
' 删除数组里指定的成员(方法一)
' total = 取数组成员数 (account)
.' 计次循环首 (total, 计次)
    .' 如果真 (account [total - 计次 + 1] = 参_name)  ' 从最后一个开始 往前
        ' 删除成员 (account, total - 计次 + 1, 1)
    .如果真结束
 
.' 计次循环尾 ()
' 调试输出 (account)
' 删除数组里指定的成员(方法二)
i = 取数组成员数 (account)
n = 1
.判断循环首 (i ≥ n)
    .如果 (account [n] = 参_name)
        删除成员 (account, n, )
        i = 取数组成员数 (account)
        n = 1
        调试输出 (i, n)
    .否则
 
    .如果结束
    n = n + 1
.判断循环尾 ()

发布日期:

所属分类: 易语言 标签: