易语言SearchPathA查找指定文件

函数原型:

DWORD SearchPathA(
  LPCSTR lpPath,
  LPCSTR lpFileName,
  LPCSTR lpExtension,
  DWORD  nBufferLength,
  LPSTR  lpBuffer,
  LPSTR  *lpFilePart
);

查找指定文件SearchPathA

.版本 2
 
.DLL命令 查找指定文件_, 整数型, "kernel32.dll", "SearchPathA", , SearchPath,Long,装载到lpBuffer缓冲区的字符数。如缓冲区长度不足,则返回缓冲区必要的长度。零表示失败。会设置GetLastError
    .参数 搜索路径, 文本型, , lppath,欲搜索的路径。如果为vbNullString,则采用windows搜索路径。参考OpenFile函数的OFSTRUCT结构中对OF_SEARCH标志搜索顺序的介绍
    .参数 欲查找文件名, 文本型, , lpfilename,要查找的文件名
    .参数 文件扩展名, 文本型, , lpextinsion,文件扩展名。必须用一个句点符号起头。如文件没有扩展名,或者lpFileName包括了扩展名,则设为vbNullString
    .参数 字串长度, 整数型, , nbufferlength,lpBuffer字串的长度
    .参数 字符串内容, 文本型, , lpbuffer,用于装载文件名的一个字串
    .参数 地址, 整数型, , lpfilepart,指定一个长整数变量,用于装载缓冲文件名部分的地址。在vb中不是特别有用

查找指定文件源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_查找指定文件_被单击
.局部变量 局部_缓冲区, 文本型
.局部变量 局部_变量, 整数型
.局部变量 局部_运行结果, 整数型
 
写到文件 (“c:\签署后的测试文件.ewt”, #文件)
局部_运行结果 = 查找指定文件_ (“c:\”, “签署后的测试文件”, “.ewt”, 0, 局部_缓冲区, 局部_变量)
局部_缓冲区 = 取空白文本 (局部_运行结果)
查找指定文件_ (“c:\”, “签署后的测试文件”, “.ewt”, 局部_运行结果, 局部_缓冲区, 局部_变量)
标签_运行结果.标题 = “您要查找的文件名是:” + 局部_缓冲区
删除文件 (“c:\签署后的测试文件.ewt”)

发布日期:

所属分类: 易语言 标签: