易语言CreateHatchBrush创建阴影矩形

画矩形Rectangle

.版本 2
 
.DLL命令 画矩形_, 整数型, "gdi32.dll", "Rectangle", , Rectangle
    .参数 设备场景, 整数型, , hdc
    .参数 左上角横坐标, 整数型, , X
    .参数 左上角纵坐标, 整数型, , Y
    .参数 右下角横坐标, 整数型, , X1
    .参数 右下角纵坐标, 整数型, , Y1

创建阴影刷子CreateHatchBrush

.版本 2
 
.DLL命令 创建阴影刷子_, 整数型, "gdi32.dll", "CreateHatchBrush", , CreateHatchBrush
    .参数 刷子阴影类型, 整数型, , nindex
    .参数 指定刷子的RGB前景色, 整数型, , crcolor

取设备场景GetDC

.版本 2
 
.DLL命令 取设备场景_, 整数型, , "GetDC", , GetDC
    .参数 窗口句柄, 整数型, , hwnd

释放设备场景 ReleaseDC

.版本 2
 
.DLL命令 释放设备场景_, 整数型, , "ReleaseDC", , ReleaseDC
    .参数 窗口句柄, 整数型, , hwnd,要释放的设备场景相关的窗口句柄
    .参数 设备场景, 整数型, , hdc,要释放的设备场景句柄

进入设备场景 SelectObject

.版本 2
 
.DLL命令 进入设备场景_, 整数型, "gdi32.dll", "SelectObject", , SelectObject
    .参数 场景句柄, 整数型, , hdc
    .参数 对象句柄, 整数型, , hobject

删除对象 DeleteObject

.版本 2
 
.DLL命令 删除对象_, 整数型, , "DeleteObject", , DeleteObject
    .参数 对象句柄, 整数型, , hObject

画阴影矩形源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_画阴影矩形_被单击
.局部变量 局部_取设备场景
.局部变量 局部_新建刷子句柄
 
局部_取设备场景 = 取设备场景_ (_启动窗口.取窗口句柄 ())
局部_新建刷子句柄 = 创建阴影刷子_ (2, 255)
进入设备场景_ (局部_取设备场景, 局部_新建刷子句柄)
画矩形_ (局部_取设备场景, 10, 50, 100, 150)
删除对象_ (局部_新建刷子句柄)
释放设备场景_ (_启动窗口.取窗口句柄 (), 局部_取设备场景)

https://docs.microsoft.com/zh-cn/windows/win32/api/wingdi/nf-wingdi-createhatchbrush?redirectedfrom=MSDN
https://docs.microsoft.com/zh-cn/windows/win32/api/wingdi/nf-wingdi-rectangle?redirectedfrom=MSDN


发布日期:

所属分类: 易语言 标签: