易语言acmGetVersion取ACM版本号

C++函数原型

DWORD ACMAPI acmGetVersion();
{ 
    DWORD   dw; 
    TCHAR   ach[10]; 
 
    dw = acmGetVersion(); 
    _stprintf_s(ach, TEXT("%u.%.02u"), 
        HIWORD(dw) >> 8, HIWORD(dw) & 0x00FF); 
}

易语言

.版本 2
 
.DLL命令 取ACM版本_, 整数型, "msacm32.dll", "acmGetVersion", , acmGetVersion

取ACM版本

.版本 2
 
.子程序 _按钮_取ACM版本_被单击
.局部变量 局部_返回值, 整数型
 
局部_返回值 = 取ACM版本_ ()
.判断开始 (局部_返回值 ≠ 0)
    标签_运行结果.标题 = “ACM 版本号:” + 到文本 (位与 (局部_返回值 \ 65536, 65535) \ 256) + “.” + 到文本 (位与 (局部_返回值 \ 65536, 255))
.默认
    标签_运行结果.标题 = “取ACM版本号失败!”
.判断结束

发布日期:

所属分类: 易语言 标签: