易语言LocalSize获取自定义数据类型大小

LocalSize

在易语言引用这个API中,参数hMem必须是我们自定义的数据类型SYSNAME,注意:可以将参数"hMem"的类型改为其他类型,并设为"传址",这样就相当于C的sizeof

.版本 2
 
.DLL命令 LocalSize, 整数型, "kernel32", "LocalSize"
    .参数 hMem, SYSNAME

自定义数据类型

SYSNAME我们可以把参数parameter设为整数,文本,逻辑,等等

.版本 2
 
.数据类型 SYSNAME
    .成员 parameter1, 整数型
    .成员 parameter2, 整数型
    .成员 parameter3, 整数型
    .成员 parameter4, 整数型
    .成员 parameter5, 文本型
    .成员 parameter5, 逻辑型

前台调用获取

这里我们声明一个局部变量,它的类型是我们自定义的数据类型SYSNAME,然后调用LocalSize

.版本 2
 
.程序集 窗口程序集1
 
.子程序 _按钮_sizeof_被单击
.局部变量 自定义数据类型, SYSNAME
 
信息框 (LocalSize (自定义数据类型), 0, , )

发布日期:

所属分类: 易语言 标签: