易语言使用推导法解决奶牛问题

前台执行源码

窗口需要两个编辑框,一个输入多少年,一个显示结果。

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 年数, 整数型, , , 保存年编辑框的数字
.局部变量 奶牛数量数组, 整数型, , "0", 数组成员数量为奶牛数量,成员内容为奶牛出生年份
.局部变量 计算数量, 整数型, , , 数组成员位置
.局部变量 计次变量, 整数型
 
' 判断输入的数值是否超出范围
.判断开始 (到数值 (输入年编辑框.内容) ≤ 0)
    信息框 (“您输入的数太小了,必须大于0,”, #错误图标, “出现错误了:”)
    返回 ()
.判断 (到数值 (输入年编辑框.内容) > 40)
    .如果真 (信息框 (“您输入的数值过大,计算将耗费一定的时间,是否继续?”, #询问图标 + #是否钮, “询问:”) = #否钮)
        返回 ()
    .如果真结束
 
.默认
 
.判断结束
年数 = 到数值 (输入年编辑框.内容)
计算数量 = 1
加入成员 (奶牛数量数组, 2)  ' 第一头奶牛第一年为2岁
.判断循环首 (计算数量 ≤ 取数组成员数 (奶牛数量数组))  ' 判断是否还有奶牛需要计算
    .计次循环首 (年数 - 奶牛数量数组 [计算数量], 计次变量)  ' 计算每一头奶牛在年数内能生多少头
        加入成员 (奶牛数量数组, 奶牛数量数组 [计算数量]4 + 计次变量 - 1)  ' 用循环增加每一头奶牛,将奶牛出生年份加入
        ' 每头奶牛生的第一头奶牛的出生年份为他自己的年份+4,以后每头累加1
    .计次循环尾 ()
    计算数量 = 计算数量 + 1
.判断循环尾 ()
显示个数编辑框.内容 = 到文本 (取数组成员数 (奶牛数量数组))

发布日期:

所属分类: 易语言 标签: