易语言PathFindFileNameA获取路径文件名

易语言API模块制作文件取文件名

取路径文件名PathFindFileNameA

.版本 2
 
.DLL命令 取路径文件名_, 整数型, "shlwapi.dll", "PathFindFileNameA", , 成功返回路径文本指针地址
    .参数 路径文本, 文本型, , pszPath

易语言调用源码:

窗口需要一个标签,一个编辑框,一个按钮。

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_标签数组, 标签, , "0"
.程序集变量 程序集_编辑框数组, 编辑框, , "0"

.子程序 __启动窗口_创建完毕
.局部变量 局部_标签变量, 标签
.局部变量 局部_编辑框变量, 编辑框
.局部变量 局部_计次, 整数型

加入成员 (程序集_标签数组, 标签1)
加入成员 (程序集_编辑框数组, 编辑框_运行结果)
.计次循环首 (9, 局部_计次)
复制窗口组件 (标签1, 局部_标签变量)
局部_标签变量.移动 (标签1.左边, 标签1.顶边 + 标签1.高度 + 标签1.高度 × (局部_计次 - 1), 标签1.宽度, 标签1.高度)
局部_标签变量.可视 = 真
复制窗口组件 (编辑框_运行结果, 局部_编辑框变量)
局部_编辑框变量.移动 (, 局部_标签变量.顶边, , )
局部_编辑框变量.可视 = 真
加入成员 (程序集_标签数组, 局部_标签变量)
加入成员 (程序集_编辑框数组, 局部_编辑框变量)
.计次循环尾 ()
程序集_标签数组 [1].标题 = “somefile.txt”
程序集_标签数组 [2].标题 = “c:\somefile.txt”
程序集_标签数组 [3].标题 = “c:\javatools\”
程序集_标签数组 [4].标题 = “c:\javatools\somefile.txt”
程序集_标签数组 [5].标题 = “..\..\”
程序集_标签数组 [6].标题 = “..\..\javatools\”
程序集_标签数组 [7].标题 = “\\workstation\javatools”
程序集_标签数组 [8].标题 = “\\192.168.1.100\d$\javatools\somefile.txt”
程序集_标签数组 [9].标题 = “http://www.microsoft.com”
程序集_标签数组 [10].标题 = “http://www.microsoft.com/ms.htm”

.子程序 _按钮_取路径文件名_被单击
.局部变量 局部_计次, 整数型
.局部变量 局部_路径, 文本型

.计次循环首 (10, 局部_计次)
局部_路径 = 程序集_标签数组 [局部_计次].标题
程序集_编辑框数组 [局部_计次].内容 = 指针到文本 (取路径文件名_ (局部_路径))
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: