易语言教程API模块制作cmd复制文件

cmd_复制文件

1、 使用cmd命令复制文件
COPY [/D] [/V] [/N] [/Y | /-Y] [/Z] [/L] [/A | /B ] source [/A | /B]
[+ source [/A | /B] [+ ...]] [destination [/A | /B]]
source 指定要复制的文件。
/A 表示一个 ASCII 文本文件。
/B 表示一个二进位文件。
/D 允许解密要创建的目标文件
destination 为新文件指定目录和/或文件名。
/V 验证新文件写入是否正确。
/N 复制带有非 8dot3 名称的文件时,
尽可能使用短文件名。
/Y 不使用确认是否要覆盖现有目标文件
的提示。
/-Y 使用确认是否要覆盖现有目标文件
的提示。
/Z 用可重新启动模式复制已联网的文件。
/L 如果源是符号链接,请将链接复制
到目标而不是源链接指向的实际文件。
命令行开关 /Y 可以在 COPYCMD 环境变量中预先设定。
这可能会被命令行上的 /-Y 替代。除非 COPY
命令是在一个批处理脚本中执行的,默认值应为
在覆盖时进行提示。
要附加文件,请为目标指定一个文件,为源指定
数个文件(用通配符或 file1+file2+file3 格式)。
CMD /C 执行,实际上是先进一个CMD,再直接执行程序,再退出此CMD

视频教程源码

.版本 2

.程序集 集_文件目录

.子程序 cmd_复制文件, , 公开, cmd复制文件
.参数 要复制的文件名, 文本型, , 源文件的路径及名称
.参数 复制到的目录名, 文本型, , 如果改名的话,重新命名文件名

要复制的文件名 = #引号 + 要复制的文件名 + #引号
复制到的目录名 = #引号 + 复制到的目录名 + #引号
运行 (“cmd.exe /c copy /y ” + 要复制的文件名 + “ ” + 复制到的目录名, 假, #隐藏窗口)


发布日期:

所属分类: 易语言 标签: