易语言大漠类单线程加集多线程模块制作及调用实战

文章目录[隐藏]

多线程模块核心源码

.版本 2

.程序集 集_多线程

.子程序 插件初始化多线程, , 公开, 执行插件命令前必须调用一次,不可以启动线程再调用,只需要调用一次即可,结束后用销毁命令来清除
.参数 数组序号, 整数型, 参考, 用来填写插件数组序号1-100整数

deimethread [数组序号].插件初始化 ()

.子程序 BindWindow, 整数型, 公开, 后台绑定窗口(返回值:0 失败,1 成功)
.参数 hwnd, 整数型, , 指定窗口的句柄
.参数 display, 文本型, , 屏幕颜色获取方式
.参数 mouse, 文本型, , 鼠标仿真模式
.参数 keypad, 文本型, , 键盘仿真模式
.参数 mode, 整数型, , 模式,见接口说明
.参数 数组序号, 整数型, 参考, 用来填写插件数组序号1-100整数

返回 (deimethread [数组序号].BindWindow (hwnd, display, mouse, keypad, mode))

.子程序 UnBindWindow, 整数型, 公开, 解除绑定窗口,并释放系统资源,(返回值:0 失败,1 成功)
.参数 数组序号, 整数型, 参考, 用来填写插件数组序号1-100整数

返回 (deimethread [数组序号].UnBindWindow ())

.子程序 KeyPress, 整数型, 公开, 按下指定的虚拟键码(返回值:0 失败,1 成功)
.参数 vk_code, 整数型, , 虚拟按键码
.参数 数组序号, 整数型, 参考, 用来填写插件数组序号1-100整数

返回 (deimethread [数组序号].KeyPress (vk_code))

.子程序 销毁, , 公开
.参数 数组序号, 整数型, 参考, 用来填写插件数组序号1-100整数

deimethread [数组序号].销毁 ()


发布日期:

所属分类: 易语言 标签: