易语言大漠模块制作教程获取颜色GetColor

视频模块源码:

.版本 2

.子程序 GetAveHSV, 文本型, 公开, 获取范围(x1,y1,x2,y2)颜色的均值,返回格式"H.S.V";返回值:(颜色字符串)
.参数 x1, 整数型, , x1 整形数: 左上角X
.参数 y1, 整数型, , y1 整形数: 左上角Y
.参数 x2, 整数型, , x2 整形数: 右下角X
.参数 y2, 整数型, , y2 整形数: 右下角Y

返回 (obj.文本方法 (“GetAveHSV”, x1, y1, x2, y2))

.子程序 GetAveRGB, 文本型, 公开, 获取范围(x1,y1,x2,y2)颜色的均值,返回格式"RRGGBB";返回值:(颜色字符串)
.参数 x1, 整数型, , x1 整形数: 左上角X
.参数 y1, 整数型, , y1 整形数: 左上角Y
.参数 x2, 整数型, , x2 整形数: 右下角X
.参数 y2, 整数型, , y2 整形数: 右下角Y

返回 (obj.文本方法 (“GetAveRGB”, x1, y1, x2, y2))

.子程序 GetColor, 文本型, 公开, 获取(x,y)的颜色,颜色返回格式"RRGGBB",注意,和按键的颜色格式相反;返回值:(颜色字符串(注意这里都是小写字符,和工具相匹配))
.参数 x, 整数型, , x 整形数:X坐标
.参数 y, 整数型, , y 整形数:Y坐标

返回 (obj.文本方法 (“GetColor”, x, y))

.子程序 GetColorBGR, 文本型, 公开, 获取(x,y)的颜色,颜色返回格式"BBGGRR";返回值:(颜色字符串(注意这里都是小写字符,和工具相匹配))
.参数 x, 整数型, , x 整形数:X坐标
.参数 y, 整数型, , y 整形数:Y坐标

返回 (obj.文本方法 (“GetColorBGR”, x, y))

.子程序 GetColorHSV, 文本型, 公开, 获取(x,y)的HSV颜色,颜色返回格式"H.S.V";返回值:(颜色字符串)
.参数 x, 整数型, , x 整形数:X坐标
.参数 y, 整数型, , y 整形数:Y坐标

返回 (obj.文本方法 (“GetColorHSV”, x, y))

.子程序 GetColorNum, 整数型, 公开, 获取指定区域的颜色数量,颜色格式"RRGGBB-DRDGDB",注意,和按键的颜色格式相反;返回值:(颜色数量)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 整数型, , color 字符串:颜色 格式为"RRGGBB-DRDGDB",比如"123456-000000|aabbcc-202020".注意,这里只支持RGB颜色.
.参数 sim, 整数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0

返回 (obj.数值方法 (“GetColorNum”, x1, y1, x2, y2, color, sim))

.子程序 GetPicSize, 文本型, 公开, 返回值:(形式如 "w,h" 比如"30,20")获取指定图片的尺寸,如果指定的图片已经被加入缓存,则从缓存中获取信息.此接口也会把此图片加入缓存. (当图色缓存机制打开时,具体参考EnablePicCache)
.参数 pic_name, 文本型, , pic_name 字符串: 文件名 比如"1.bmp"

返回 (obj.文本方法 (“GetPicSize”, pic_name))

.子程序 GetScreenData, 整数型, 公开, 获取指定区域的图像,用二进制数据的方式返回,(不适合按键使用)方便二次开发.返回值:(返回的是指定区域的二进制颜色数据地址,每个颜色是4个字节,表示方式为(00RRGGBB))
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标

返回 (obj.数值方法 (“GetScreenData”, x1, y1, x2, y2))

.子程序 GetScreenDataBmp, 整数型, 公开, 获取指定区域的图像,用24位位图的数据格式返回,方便二次开发.(或者可以配合SetDisplayInput的mem模式)返回值:(0失败,1成功。)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 data, 整数型, 参考, data 变参指针:返回图片的数据指针
.参数 size, 整数型, 参考, size 变参指针:返回图片的数据长度

返回 (obj.数值方法 (“GetScreenDataBmp”, x1, y1, x2, y2, data, size))

视频教程优酷土豆播放链接


发布日期:

所属分类: 易语言 标签: