易语言教程数组操作清除数组和数组清零

官方文档

清除数组
调用格式: 〈无返回值〉 清除数组 (通用型变量数组 欲删除成员的数组变量) - 系统核心支持库->数组操作
英文名称:RemoveAll
删除指定数组变量中的所有成员,释放这些成员所占用的存储空间,重新定义该变量为单维 0 成员数组变量。本命令为初级命令。
参数<1>的名称为“欲删除成员的数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。

操作系统需求: Windows、Linux、Unix
数组清零
调用格式: 〈无返回值〉 数组清零 (通用型变量数组 数值数组变量) - 系统核心支持库->数组操作
英文名称:ZeroAry
将指定数值数组变量内的所有成员值全部设置为零,不影响数组的维定义信息。本命令为初级命令。
参数<1>的名称为“数值数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。

操作系统需求: Windows、Linux

视频教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 数组, 整数型, , "10"

.子程序 __启动窗口_创建完毕

.子程序 初始化数组
.局部变量 i, 整数型
.局部变量 n, 整数型
.局部变量 分割符, 文本型

置随机数种子 ()
编辑框1.内容 = “”
.计次循环首 (10, i)
数组 [i] = 取随机数 (1, 10)
.计次循环尾 ()
.计次循环首 (10, n)
编辑框1.加入文本 (分割符, 到文本 (数组 [n]))
分割符 = “,”
.计次循环尾 ()
编辑框1.加入文本 (#换行符)

.子程序 _按钮3_被单击, , , 初始化数组

初始化数组 ()

.子程序 _按钮1_被单击, , , 删除指定数组变量中的所有成员,释放这些成员所占用的存储空间,重新定义该变量为单维 0 成员数组变量。

清除数组 (数组)
调试输出 (数组)
信息框 (取数组成员数 (数组), 0, , )

.子程序 _按钮2_被单击, , , 将指定数值数组变量内的所有成员值全部设置为零,不影响数组的维定义信息。本命令为初级命令。
.局部变量 n, 整数型
.局部变量 分割符, 文本型

数组清零 (数组)
.计次循环首 (取数组成员数 (数组), n)
编辑框1.加入文本 (分割符, 到文本 (数组 [n]))
分割符 = “,”
.计次循环尾 ()
延迟 (1000)
信息框 (取数组成员数 (数组), 0, , )


发布日期:

所属分类: 易语言 标签: